提供: すだちWiki
移動先: 案内検索

PHP 7.3 から PHP 7.2 へダウングレード(CentOS8)

メインページ > CentOS_8_で自宅サーバー構築  > PHP 7.3 から PHP 7.2 へダウングレード(CentOS8)

  • 自宅サーバーで、動作確認しています。導入される方は自己責任で行ってください。
  • WordPress 5.3.2 動作しています。
  • MediaWiki 1.34.0 動作しています。
  • EPELリポジトリ、Remiリポジトリを導入済みとします。

CentOSバージョン確認

[root@host4 ~]# cat /etc/redhat-release
CentOS Linux release 8.1.1911 (Core)

ダウングレード

有効になっている PHP のバージョンを確認

[root@host4 ~]# dnf module list php
CentOS-8 - AppStream
Name                Stream                 Profiles                                 Summary                             
php                 7.2 [d]                common [d], devel, minimal               PHP scripting language              
php                 7.3 [e]                common, devel, minimal                   PHP scripting language

Stream切り替え

[root@host4 ~]# dnf distro-sync

[root@host4 ~]# dnf module reset php

[root@host4 ~]# dnf module enable php:7.2

ダウングレード実行

  • PHP 7.2 にダウングレード
[root@host4 ~]# dnf distro-sync

メタデータの期限切れの最終確認: 0:04:42 時間前の 2020年03月30日 19時18分08秒 に実施しました。
依存関係が解決しました。
========================================================================================================================
 パッケージ              アーキテクチャー バージョン                                          リポジトリー        サイズ
========================================================================================================================
ダウングレード:
 php-cli                 x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream           3.1 M
 php-common              x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream           655 k
 php-devel               x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream           712 k
 php-fpm                 x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream           1.6 M
 php-gd                  x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream            84 k
 php-gmp                 x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream            75 k
 php-json                x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream            73 k
 php-mbstring            x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream           581 k
 php-mysqlnd             x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream           190 k
 php-opcache             x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream           230 k
 php-pdo                 x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream           122 k
 php-pear                noarch           1:1.10.5-9.module_el8.1.0+209+03b9a8ff              AppStream           358 k
 php-pecl-apcu           x86_64           5.1.12-2.module_el8.1.0+209+03b9a8ff                AppStream            65 k
 php-process             x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream            84 k
 php-xml                 x86_64           7.2.11-2.module_el8.1.0+209+03b9a8ff                AppStream           189 k

トランザクションの概要
========================================================================================================================
ダウングレード  15 パッケージ

php7.2インストール済みパッケージ確認

[root@host4 ~]# rpm -qa | grep php
php-pear-1.10.5-9.module_el8.1.0+209+03b9a8ff.noarch
php-opcache-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64
php-common-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64
php-xml-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64
php-fpm-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64
php-mbstring-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64
php-process-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64
php-devel-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64
php-json-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64
php-pdo-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64
php-mysqlnd-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64
php-gmp-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64
php-pecl-apcu-5.1.12-2.module_el8.1.0+209+03b9a8ff.x86_64
php-cli-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64
php-gd-7.2.11-2.module_el8.1.0+209+03b9a8ff.x86_64

php.iniの設定

[root@host4 ~]# vi /etc/php.ini

# [PHP]ブロック
expose_php = Off ← レスポンスヘッダにPHPのバージョンを表示させない
error_reporting = E_ALL ← 全てのログを出力させる
display_errors = Off ← ブラウザでのエラー表示させない
log_errors = On ← エラーをログに残す
log_errors_max_len = 4096 ← エラーログの長さを設定、念のため大きめに
error_log = "/var/log/php_errors.log" ← エラーログ出力先
default_charset = "UTF-8" ← 文字エンコーディング

#[Date]ブロック
date.timezone = "Asia/Tokyo" ← タイムゾーン

#[mbstring]ブロック
mbstring.language = Japanese ← デフォルト言語
mbstring.internal_encoding = UTF-8 ← 内部文字エンコーディング
mbstring.http_input = auto ← HTTP入力文字エンコーディングのデフォルト
mbstring.detect_order = auto ← 文字エンコーディング検出順序のデフォルト

php-fpmの再起動

[root@host4 ~]# systemctl start php-fpm

Webサーバー再起動

[root@host4 ~]# systemctl restart httpd

phpバージョン確認

[root@host4 ~]# php -v
PHP 7.2.11 (cli) (built: Oct  9 2018 15:09:36) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.11, Copyright (c) 1999-2018, by Zend Technologies