提供: すだちWiki
移動先: 案内検索

Yum の 'Not using downloaded repomd.xml because it is older than what we have' エラー対策(CentOS7)

はじめに

CentOS 7 自宅サーバーで起きた yum update 関係のエラーです。

現象

cron.hourly が以下のようなメールを送信するようになった。

/etc/cron.hourly/0yum-hourly.cron:

Not using downloaded repomd.xml because it is older than what we have:
  Current   : Thu May 14 01:30:54 2015
  Downloaded: Wed Apr 29 06:32:44 2015

原因

yum のキャッシュが残っているかららしい。

対策

yum のキャッシュを削除する。

[root@host3 ~]# yum clean all
読み込んだプラグイン:fastestmirror, priorities
リポジトリーを清掃しています: base extras isv_ownCloud_community rpmforge updates
Cleaning up everything
Cleaning up list of fastest mirrors